X.org7

Аватар пользователя slavikVA

Подскажите ,если не трудно, какие пакеты необходимы для нормальной работы XOrg 7.1, или же нужно ставить все что есть в паке src на http://ftp.x.org/pub/X11R7.1/src/. Или есть другой путь перехода с x.org 6.8.2 на x.org7.1 ?

Аватар пользователя Meloman

Re: x.org7

Признаться, у меня был неудачный опыт построения XOrg 7.0 на ASP: Выдавалась какая-то ошибка уже не из-за того, что не хватает каких-то пакетов, а из-за того, что он не смог скомпилировать файл.
Поэтому я для себя решил не торопиться, и ждать уже собранных пакетов.
(Все вышенаписанное относится не только к XOrg... Но и за конечное мнение его принимать не нужно).

Аватар пользователя IsakovAN

Re: x.org7

Аватар пользователя Tigro

Re: x.org7

Можно перейти на 6.9.0 это чистый 7.0!

Аватар пользователя IsakovAN

Re: x.org7

Tigro писал(а):
Можно перейти на 6.9.0 это чистый 7.0!

Ага! Только не модульный.
И зачем он нужен, если 7.1 есть?

Аватар пользователя Meloman

Re: x.org7

Это я в начале ответил про то, что пытался собрать 7.0...

Аватар пользователя Tigro

Re: x.org7

IsakovAN писал(а):
Ага! Только не модульный.
И зачем он нужен, если 7.1 есть?

Затем, что он уже собранный есть. И собирать его гораздо проще.

Аватар пользователя IsakovAN

Re: x.org7

Tigro писал(а):
И собирать его гораздо проще.

Угу.
emerge xorg-x11
Катается от смеха
У нас 6.9 был замаскирован прежде чем его кто-то успел поставить, т.к. сразу для 7 ebuild появился.

Аватар пользователя Tigro

Re: x.org7

Ну нашел, в чем жента круче, убедил...

Аватар пользователя Ali

Re: x.org7

Интересно! А compiz,beril,xgl ... на 6.9 встанут?

Аватар пользователя IsakovAN

Re: x.org7

Tigro писал(а):
Ну нашел, в чем жента круче, убедил...

Я не к тому говорил, чтобы пиписьками мериться Улыбка, а к тому, что нафига 6.9 ставить, когда 7.1 есть? Если gentoo-team ebuild смогла сделать, так и ASPшники могли бы уже давно своих спеков наклепать.

Ali писал(а):
Интересно! А compiz,beril,xgl ... на 6.9 встанут?

Нет. У них в требованиях МОДУЛЬНЫЕ иксы! Т.е. xorg-x11 > 7.0

Аватар пользователя Ali

Re: x.org7

IsakovAN

Цитата:
....6.9 ставить, когда 7.1 есть? Если gentoo-team ebuild смогла сделать, так и ASPшники могли бы уже давно своих спеков наклепать.

По моему это тот случай для рпм-дистра когда проще сделать ASP12 = FC6.

Аватар пользователя Tigro

Re: x.org7

compiz/xgl пойдет к 6.9.0!!!!! Так сделано в 11.2.

Аватар пользователя Ali

Re: x.org7

Tigro

Цитата:
compiz/xgl пойдет к 6.9.0!!!!! Так сделано в 11.2.

Если можно подробней. Т.к. после типовой инсталяции с двд нет и намека.

Аватар пользователя IzumeRoot

Re: x.org7

Ali писал(а):
Tigro
Цитата:

compiz/xgl пойдет к 6.9.0!!!!! Так сделано в 11.2.

Если можно подробней. Т.к. после типовой инсталяции с двд нет и намека.

Это тот, который beryl ? А вот мне очень интересно (пока диск с 11.2 в пути) установится ли beryl на АСП-овском xorg 6.9 ?

Аватар пользователя IzumeRoot

Re: x.org7

А на карточке от ati будет пахать?

Аватар пользователя RedBeard

Re: x.org7

IzumeRoot писал(а):
А на карточке от ati будет пахать?

Скорее всего, не будет. Они сейчас не этим заняты, они уже не сами по себе, их AMD купила.

Аватар пользователя RedBeard

Re: x.org7

IzumeRoot писал(а):
А на карточке от ati будет пахать?

Рекомендация: подбирай старые дрова, как я сам сделал (у меня Radeon 9250, дрова - radeon, не fglrx!!! Установлена как 9200SE, и пашет нормально!) Забыл сказать: у меня Xorg 6.9.

Аватар пользователя Ali

Re: x.org7

[ali@alic ~]$ rpm -qa | grep xgl
xgl-1.1.99.1-0.10.cvs060522.112asp
xgl-hardware-list-060526-1.10.112asp
[ali@alic ~]$ cat /etc/asplinux-release
ASPLinux release 11.2 (Ladoga)

Все необходимое для 11.2 в варианте рабочая станция с двд :
Installing:
compiz i386 0.0.13-1.16.cvs060616.112asp asplinux-updates 410 k
gset-compiz i386 0.3.3-3.112asp asplinux-updates 81 k
xgl i386 1.1.99.1-0.10.cvs060522.112asp asplinux-updates 1.5 M
Installing for dependencies:
libdrm i386 2.0-13.112asp asplinux-updates 16 k
libsvg i386 0.1.4-4.112asp asplinux-updates 60 k
libsvg-cairo i386 0.1.6-3.112asp asplinux-updates 30 k
xgl-hardware-list noarch 060526-1.10.112asp asplinux-updates 8.8 k
лежит здесь http://download.asplinux.ru/i386/updates/11.2/i386/ .
Если позволяет сеть в /etc/yum.repos.d/asplinux-updates.repo заменить .enabled=0 на enabled=1

#yum install gset-compiz compiz xgl
# gnome-xgl-switch --enable-xgl
#reboot

IzumeRoot

Цитата:
А на карточке от ati будет пахать?

В xgl-hardware-list содержится список карт.
Теперь о грустеом. Хотя все работает, вроде, правильно и стабильно, но черезвычайно медлено (414 frames in 6.5 seconds = 63.411 FPS). Что на порядок хуже
FC6 (2566 frames in 5.0 seconds = 513.180 FPS)или Mandriv`ы. Как поправить?
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)

Аватар пользователя RedBeard

Re: x.org7

Никому не советую драйвера fglrx! Очень уж глючные!!! Radeon стабильно работает.

Аватар пользователя IsakovAN

Re: x.org7

RedBeard писал(а):
Никому не советую драйвера fglrx! Очень уж глючные!!! Radeon стабильно работает.

А nvidia еще лучше! Катается от смеха
И XGLи не нужны.

Аватар пользователя RedBeard

Re: x.org7

IsakovAN писал(а):
RedBeard,
Цитата:

Никому не советую драйвера fglrx! Очень уж глючные!!! Radeon стабильно работает.

А nvidia еще лучше!
И XGLи не нужны.

В общем, согласен! Но что же мне теперь - карточку новую покупать?

RSS-материал